1074

Trongate Desktop App. Error: SCRIPT FAILED TO EXECUTE...

Showing 11 to 17 of 17 comments.

Comments for “Trongate Desktop App. Error: SCRIPT FAILED TO EXECUTE...”
 

Posted by mbrick02 on Wednesday 13th April 2022 at 21:18 GMT

I'm not sure how...but this could be a Windows Update issue...I'll let you know after I finish my update...
Founding Member

mbrick02

User Level: Founding Member

Date Joined: 5/12/2018

Posted by DaFa on Thursday 14th April 2022 at 05:56 GMT

hmm I would be surprised if after a Windows update it started working for you. And having Windows home should not make any difference with the Desktop app.

Could you confirm you have tried the following:

Delete the desktop app from where ever you unzipped it to, redownload the latest version from https://github.com/davidjconnelly/trongate-framework/releases/download/v1.3.3031/Trongate-1.0.4-win.zip or the link from https://trongate.io/download - which ever makes you feel good. Unpack this zip file to a place where you have full read-write access to, maybe C:/Winapps/Trongate

Delete the config folder 'Trongate' from %appdata%

Ensure your webstack is loaded and running - i.e Xampp (both Apache and MySQL are running - green lighted)

Test localhost in a browser - it should show the Xampp dashboard if Xampp is your webstack

Run the Trongate Desktop app (should open with the v1.0.004 window - click OKAY) then create a new app, call it 'z1', choose a location (htdocs - if you have xampp installed) - view your app in the browser (should open to http://localhost/z1/) and say 'It Totally Works'

In the Desktop app - select reset, it will flash a bit, then select 'Modify Existing App', select 'z1' > Does it give you that error now? if not continue in your favourite text editor - open 'z1' and edit the licence file you see in the 'engine' folder of the 'z1' app, then change the version number from 1.3.3045 to something smaller like 1.3.1000. Save it and go back to the desktop app (select 'RESET' if it is still open), then try 'Modify Existing App' once more. Choose the 'z1' folder, and if it doesn't show the error page you should be seeing 'TRONGATE 1.3.3035 IS AVAILABLE', select either option 'UPDATE to 1.3.3035' or 'CONTINUE USING 1.3.1000'.

If you chose to update, the licence file should now be reverted back to 1.3.3035 and the Desktop app will display a successfully updated framework - click 'OKAY' and you should now be brought back to the main blue Trongate page on the Desktop app.

If at ANY of the stages above you get that error, please advise.

If it is an older app previously created with an older version of the Desktop app, try creating a new app with this current version and copy your modules over along with any public folders you may have changed, then try modifying the app again - then let me know where the error pops up...

This comment was edited by DaFa on Thursday 14th April 2022 at 08:49 GMT

Founding Member

DaFa

User Level: Founding Member

Date Joined: 30/11/2018

Posted by mbrick02 on Thursday 14th April 2022 at 18:26 GMT

You were right in thinking the windows update DID NOT matter (I had looked up a similar error message elsewhere where the update seemed to the culprit, but not so here).

I was able to create the new app and recreate the old app. So really, all is good. But...
If possible, I would like to use my git repository on both machines.
What I'm going to try is copying over the new engine and config folder to the old repository and seeing if it will work.
If that doesn't work...no real worries...
let me know if you think any other folders would be the culprits, but otherwise I'll just upload the new version to a new repository.
In any case, I'll consider this case closed -- do I close it or does the site admin?

Thanks so much!
Founding Member

mbrick02

User Level: Founding Member

Date Joined: 5/12/2018

Posted by djnordeen on Thursday 14th April 2022 at 20:46 GMT

You close it by selecting the correct answer, the star

Dan
Early Adopter

djnordeen

User Level: Early Adopter

Date Joined: 20/08/2021

Posted by mbrick02 on Friday 15th April 2022 at 16:24 GMT

Duh! Thanks, Dan!
Founding Member

mbrick02

User Level: Founding Member

Date Joined: 5/12/2018

Posted by anunes on Friday 10th May 2024 at 13:15 GMT

I get a javascript error creating a new app with Trongate app on Mac Sonoma. And the app will not finish.
Here's the (long) error:

Uncaught Exception:
Error: ER_NOT_SUPPORTED_AUTH_MODE: Client does not support authentication protocol requested by server; consider upgrading MySQL client
at Sequence._packetToError (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/sequences/Sequence.js:47:14)
at Handshake.ErrorPacket (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/sequences/Handshake.js:123:18)
at Protocol._parsePacket (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/Protocol.js:291:23)
at Parser._parsePacket (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/Parser.js:433:10)
at Parser.write (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/Parser.js:43:10)
at Protocol.write (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/Protocol.js:38:16)
at Socket. (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/Connection.js:88:28)
at Socket. (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/Connection.js:526:10)
at Socket.emit (node:events:513:28)
at addChunk (node:internal/streams/readable:324:12)
--------------------
at Protocol._enqueue (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/Protocol.js:144:48)
at Protocol.handshake (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/protocol/Protocol.js:51:23)
at Connection.connect (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/Connection.js:116:18)
at Connection._implyConnect (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/Connection.js:454:10)
at Connection.query (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql/lib/Connection.js:196:8)
at /Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql-import/mysql-import.js:65:16
at /Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql-import/mysql-import.js:136:3
at new Promise ()
at slowLoop (/Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql-import/mysql-import.js:131:9)
at /Applications/Trongate.app/Contents/Resources/app.asar/node_modules/mysql-import/mysql-import.js:63:4

anunes

User Level: Guest

Date Joined: 4/07/2021

Posted by DaFa on Saturday 11th May 2024 at 01:56 GMT

Hi anunes, please create a new thread... Just a heads up - Macs are very picky with permissions. What I'm seeing in that error dump is your MySQL install hasn't permitted the Desktop app to use whatever user (root, etc...) you set when creating the Trongate app.
Founding Member

DaFa

User Level: Founding Member

Date Joined: 30/11/2018

×